Forum speed selector wont go past gentle stir

10 posts | Last post

Hi rhondamargarita

Sorry to hear you experienced this.

We have passed your comment onto our Customer Service team. Someone will be in contact to discuss with you shortly.

Warm regards

Thermomix Head Office

Does anyone have an answer for this problem? As my TM 31 has just done this tonight.

I was about to make Creamed Rice and luckily the gentle stir was enough to make it.

Hi JuluaToohey

Sorry to hear about the issue you are having. We have flagged your post with our Customer Service Team. A member of the team will be contacting you directly.

We thankyou for your patience. Please call 1800 004 838 if you require more immediate assistance.

Kind Regards

Thermomix Head Office

Just had the same problem. Blades turn om gentle stir, but can't get the dial on my TM 31 to go past that position.

Hi richelle1982,

We have flagged your post with our Service team, and someone will be in touch with you soon. Please bear with us in the meantime.

Thermomix Head Office

I'm just wondering what thermomix have said/if they have replied as the same thing has happened to my thermomix tonight and I'm wondering what to do. I'm waiting to hear back from my demonstrator too


Thank you very much Smile

Hi Sandylovestocook,

We have flagged your post with our Service team. Someone from our Service team will be in touch to advise.

Thermomix Head Office

Can someone help me.

I've just tried my thermomix TM31 and I can't seem to get the speed dial to go past gentle stir, please help me as I dont know what to do, I've tried the troubleshooting on pages 35 and 40  but they aren't working and it's near dinner time.sppe